Views: 7,152,799 Homepage | Main | Rules/FAQ | Memberlist | Active users | Last posts | Calendar | Stats | Online users | Search 05-20-24 10:57 PM
Guest:

0 users reading LAN/Netplay dev thread | 1 bot

Main - Development - LAN/Netplay dev thread Hide post layouts | New reply


Arisotura
Posted on 10-07-23 03:08 PM Link | #6248
Opening this thread to collect all test reports and such from the season2 branch.

____________________
Kuribo64

Player 3
Posted on 10-25-23 07:15 PM Link | #6276
Tried same PC local multiplayer on the latest season2 build listed for Windows x86_64

Game: Phantasy Star 0
Seems to be more finicky in LAN requirements than the other game I tried
2 players OK can join normally and play
3 players ERROR as soon as third instance of melonDS joins the lobby player 2 refuses to connect anymore
melonDS 0.9.5 not able to connect 3 player in the lobby formation screen, massive slowdown when tried to join lobby

Game: Final Fantasy Crystal Chronicles Echoes of Time
2 players OK can join normally and play
3 players ERROR as soon as third instance of melonDS joins the lobby player 2 refuses to connect anymore
melonDS 0.9.5 was able to hold 3 player connections to completion of the game

Woflje
Posted on 11-07-23 10:34 PM (rev. 3 of 11-10-23 04:01 PM) Link | #6297
Branch: season2
OS: Windows11/Windows10
Build/Run: This one
Game: New Super Mario Bros. (VS 1on1 star collector multiplayer game)

Every test, the host was a Windows11 PC, and the client a Windows10 PC.

Test 1:
Host and Client connected to same network - LAN
Had the time of my life, can't believe how well it works, no problems found

Test 2:
Host and Client not on the same network, but tried to get it to work using Hamachi
As soon as multiplayer in-game started, both Host and Client experienced unplayable lag
Tried using a VPN connection using Softether, but got the same result

Test 3:
Tried to use Netplay. (I know it was broken as stated in this post)

Host:
If first Netplay host was set in system->multiplayer->Netplay, no roms could be loaded after
If the rom was loaded first, the game runs fine in main menu.
As soon as the multiplayer connection was started in-game, the game stated that the client had left, but MelonDS kept running the game fine.

Client:
If first Netplay join server was set in system->multiplayer->Netplay, no roms could be loaded after
If the rom was loaded first, the game runs fine in main menu.
As soon as the multiplayer connection was started in-game, the MelonDS application quits itself / crashes

Test 4:
Was thinking about the Remote Play Together feature from Steam. Found the Moon Light streaming software. I have two laptops on my network so I made my secondary laptop stream a MelonDS instance over Moon Light to player 2. Then connected the instances over LAN. Minor input-delay, but really playable.
Not sure whether I should be proud or ashamed for this setup but I really wanted to play NDS Mario Bros VS with my sister who lives in another city


Main - Development - LAN/Netplay dev thread Hide post layouts | New reply

Page rendered in 0.029 seconds. (2048KB of memory used)
MySQL - queries: 30, rows: 83/83, time: 0.020 seconds.
[powered by Acmlm] Acmlmboard 2.064 (2018-07-20)
© 2005-2008 Acmlm, Xkeeper, blackhole89 et al.