Views: 5,249,715 Homepage | Main | Rules/FAQ | Memberlist | Active users | Last posts | Calendar | Stats | Online users | Search 06-06-23 08:38 PM

0 users reading I can't get into the underground in Pokemon Diamond | 1 bot

Main - General - I can't get into the underground in Pokemon Diamond Hide post layouts | New reply

Posted on 11-28-22 04:22 PM Link | #5669
When I try to enter the underground using the Expedition Set? (たんけんセット in Japanese), the screen goes blackout and freezes.
Is there a way to fix this?

melonDS 0.9.5
Pokemon Diamond (Japanese)

Generic aka RSDuck
Posted on 11-28-22 04:32 PM (rev. 2 of 11-28-22 04:32 PM) Link | #5670
By any chance do you have separate savefile enabled? If so please try disabling it.

In case that doesn't work, please can you tell me whether it is possible to consistently trigger the problem? And if yes, please upload your savefile so we can further investigate the issue.

Take me to your heart / never let me go!

"clearly you need to mow more lawns and buy a better pc" - Hydr8gon

Posted on 11-28-22 06:12 PM Link | #5671
thank you for your quick reply. i was surprised, to be honest.
i don't have separate save file enabled.
and trying to go to the underground always causes this problem.

here is the savefile
if you cant use this url, please specify an uploader that is convenient for you.

Posted on 11-29-22 05:27 AM Link | #5675
Hm, this is weird.

Your save file works here with melonDS 0.9.5 on my machine. Maybe your BIOS/firmware or ROM file are bad?

If you are using a BIOS/firmware dump from a real console, can you try enabling the option to use the internal BIOS/firmware in the "Emu settings" dialog? Might also be possible the ROM got corrupted when transferring it, can you try dumping it again and to be safe, try using the version that is not trimmed.

Posted on 11-29-22 11:03 AM Link | #5676
thank you for your reply

you mean i should uncheck the box "Use external BIOS/firmware files"?
i tried but the game blacked out and froze

i also tried the untrimmed version, but this didnt solve the problem

reinstalling melonDS also didn't work

by the way, NO$GBA did not cause this problem with the trimmed software, so it does not necessarily seem to be a ROM issue..

Posted on 03-16-23 11:37 AM (rev. 2 of 03-16-23 11:41 AM by Arisotura) Link | #5906
If you still haven't solved the problem, you can try enable "EMU Setting > CPU Emulation > JIT Recompiler" After testing this method is available on modified Chinese ROM, I found it in a Chinese community" LINK REMOVED "By the way, this passage was translated from Chinese to English using Google Translate, so it may seem a little strange

Posted on 03-16-23 11:42 AM Link | #5907
please don't post links to ROMs, these are copyrighted material


Posted on 03-19-23 04:02 PM (rev. 2 of 03-19-23 04:10 PM) Link | #5910
Posted by Arisotura
please don't post links to ROMs, these are copyrighted material

I didn't post a ROM, the page was actually Chinese discussing bugs about underground. Is it not allowed even then? As you can see, I'm new here and don't know much about the rules yet.
That web page has nothing to do with ROM. I found a workable solution there, and in order to protect the copyright of the person who proposed the method, I wrote the link there. If this is not allowed, then I will not do it again

Main - General - I can't get into the underground in Pokemon Diamond Hide post layouts | New reply

Page rendered in 0.024 seconds. (2048KB of memory used)
MySQL - queries: 30, rows: 93/93, time: 0.014 seconds.
[powered by Acmlm] Acmlmboard 2.064 (2018-07-20)
© 2005-2008 Acmlm, Xkeeper, blackhole89 et al.