Views: 2,480,961 Homepage | Main | Rules/FAQ | Memberlist | Active users | Last posts | Calendar | Stats | Online users | Search 07-27-21 02:37 PM

0 users reading melonDS Wifi with blocked DNS | 1 bot

Main - General - melonDS Wifi with blocked DNS New reply

Posted on 04-17-19 11:35 AM Link | #1009

I've used melonDS in direct mode to connect to the Wiimmfi DNS servers and it works great.
However I'm now in a location where access to custom DNS servers is blocked.

I tried using a VPN I set up, however it seems that traffic from melonDS isn't tunneled through the VPN.
I guess this is because it's treated as a separate device on the network?

So, I was wondering if anyone had experienced something similar and had a workaround, or knew how to tunnel
melonDS traffic through a VPN.


Posted on 04-17-19 11:45 AM Link | #1010
Posted by Oppo
I guess this is because it's treated as a separate device on the network?

yup, that's it.

no idea how to solve that issue tho, maybe using a loopback adapter?


Posted on 04-17-19 11:49 AM Link | #1011
That depends, does your VPN program creates a virtual network adapter?

Posted on 04-17-19 07:15 PM Link | #1012
Thanks to you both to your quick reply!

I'm using windows as my client with melonDS, just to clarify.

I have a loopback interface, but I'm not quite sure where to proceed from there.
Would a first step be to select this adapter from direct mode, I can see it there, for what it's worth.

Yes, it creates a network adapter, but it seems that only packets from my main IP are tunneled through that adapter,
whereas packets from melonDS are simply being sent to the default gateway of my main interface.

Thanks again for any help!

Posted on 04-17-19 07:20 PM Link | #1013
did you try selecting the VPN adapter in melonDS's wifi settings?


Posted on 04-17-19 07:44 PM (rev. 2 of 04-17-19 08:13 PM) Link | #1014
Yeah, so if i set the VPN adapter as the interface under direct mode it seems I get error 52000.
Looking at wireshark, it looks like melonDS is emitting lots of DHCP requests which aren't satisfied.

I thought maybe giving it a static IP instead would work, and so I gave it something on that adapter's subnet, but I then got an error 52100.
Looking at wireshark again, it seems like melonDS is emitting lots of ARP requests which aren't satisfied.

My expertise is a little shallow from there, but maybe there's something obvious to try next?

For what it's worth, going the loopback route, I've also tried using windows internet connection sharing to share my ethernet adapter with the loopback.
However it seems that when I select the loopback from melonDS Wifi settings, DHCP requests over the loopback by melonDS are still unanswered, hence another Error 52000.

Maybe there's something I'm doing wrong when sharing the connection?

I'll keep looking from my end, and thanks again to you both.

Posted on 04-17-19 08:30 PM Link | #1015
try sharing between the VPN adapter and loopback?


Posted on 04-18-19 10:03 PM Link | #1016
Unfortunately sharing between the VPN adapter and loopback gives the same 52000 error code.

After looking into it a little more I'm a little confused as to why sharing the loopback doesn't work.
Shouldn't using ICS from my ethernet to the loopback provide DHCP and NAT services for any device connected to the loopback?
From there a melonDS connected to the loopback should be NAT'ed to my ethernet IP and sent over the VPN...
However it seems that all DHCP requests when melonDS is in direct mode and connected to the loopback are not responded to, it only gets responses from my local router when direct mode connects to my main ethernet, which then results in the DNS requests being firewalled.

BTW: I also tried working with indirect mode.
From this I was able to confirm with tcpdump on my VPN server that DNS packets were being sent through the VPN to Wiimmfi's DNS servers.
However in the end I received an Error code 20100 still.
(I also tried the Kearu WFC DNS and got the same error).

Any thoughts?

Posted on 04-19-19 12:22 PM Link | #1019
So it looks like running it in a VM on my machine does the trick.
The adapter the VM sets up supports DHCP and NATs the melonDS's IP to my ethernet IP which is then tunneled over the VPN.

It's a bit of a workaround but I guess it works!

Main - General - melonDS Wifi with blocked DNS New reply

Page rendered in 0.026 seconds. (2048KB of memory used)
MySQL - queries: 29, rows: 94/94, time: 0.021 seconds.
[powered by Acmlm] Acmlmboard 2.064 (2018-07-20)
© 2005-2008 Acmlm, Xkeeper, blackhole89 et al.