Views: 6,042,262 Homepage | Main | Rules/FAQ | Memberlist | Active users | Last posts | Calendar | Stats | Online users | Search 12-09-23 05:58 AM

0 users reading Pokemon B/W WiFi Error 86420, Failed to Respond, Endless Loop | 1 bot

Main - General - Pokemon B/W WiFi Error 86420, Failed to Respond, Endless Loop Hide post layouts | New reply

Pages: 1 2
Posted on 08-22-21 01:30 AM (rev. 2 of 08-22-21 01:47 AM) Link | #4277
Trying to battle with a friend over WiFi, both using indirect mode. We're using AltWFC (

We have each other's friend codes and can see each other in the club room, but when trying to interact at all, it loads for a while before giving an error message (86420) to whoever was interacted with. The player who triggered the interaction stays in the room, getting the message that the other person failed to respond.

I'm using White, my friend is using Black.

We have tried turning audio sync and limit framerate on and off, and we have tried forwarding UDP ports like Nintendo support says might be necessary, just in case. We've also tried with patched and unpatched ROMs. Nothing we have tried seems to fix it.

Any suggestions?

I should note that mystery gifts work fine as well, just actually trying to interact with another player causes issues.

Posted on 08-22-21 01:53 AM Link | #4278
Hmm... I can't say for sure. But I will give my opinion based on my own experience.
I have the same issue in Gen IV games while connecting to Wiimmfi DNS.
What I realized is that when I connect to my Wi-Fi access point in the two laptops, it never works. But when I create a Wireless hotspot using my mobile phone 4G and connect one of the instances to this while the other is connected to my router's Wi-Fi, it works.
So, in my theory, this problem is caused by the access point you are connecting to. Are you two using the same Wireless network?
Could you please try to do a test, connecting to a hotspot instead, and check if it works?

Posted on 08-22-21 02:12 AM Link | #4279
To answer your first question, no, we're on different networks. Second, we both just tried to use mobile hotspots and no dice.

I will also mention that we just tried switching to Wiimmfi, and instead of giving an error, it simply loads forever. Same thing on a wireless hotspot. Any other ideas?

(post deleted) #4280

Posted on 08-22-21 04:57 AM Link | #4281
Decided to compare using both Wiimmfi and AltWFC, and had my friend ping as well for good measure.

AltWFC (, Wi-Fi
My TTL = 40
Friend's TTL = 50

AltWFC ( Hotspot
My TTL = 51
Friend's TTL = 51

Wiimmfi (, Wi-Fi
My TTL = 46
Friend's TTL = 44

Wiimmfi (, Hotspot
My TTL = 47
Friend's TTL = 46

So the AltWFC hotspot TTLs matched, so we gave it another shot. Still nothing.

Posted on 08-22-21 11:03 AM Link | #4282
Well, my assumption was that maybe if the packets are traveling by the same routers, the same gateway, it could cause some collisions somehow.
I tested many cases (Gen IV Pokémon Games, Gen V Pokémon Games, Mario Kart DS), using different mobile phones, different laptops, and the result was always the same: case c) works, the other cases fails.
I usually connect to the DNS

But in your case, you and your friend are not even sharing the same network, so I don't know why exactly this error happens.

Posted on 08-22-21 04:01 PM Link | #4283
This error can happen because either the router or a bad firmware, check if your firmware is bootable (if you didn't get it from a DS or 3DS). If it isn't, then it's probably a bad image.
If it isn't the issue, try erasing the WFC settings and try again, as referred on the Extra Step on the WFC tutorial here:

Connections from the same router should work, I did it myself with my brother in the same LAN back in the day.

Posted on 08-22-21 07:48 PM Link | #4286
The firmware seems to boot normally, and we have both tried erasing WFC settings multiple times. Doesn't seem to make any difference.

Posted on 08-22-21 08:07 PM Link | #4287
This sounds to be an ISP problem then. Some ISPs have the bad habit of denying DNS requests. The only way to circumvent this is either trying another WFC server or domain-patching the ROM.

Posted on 08-22-21 09:38 PM Link | #4288
My friend isn't available right now so I tried this myself with two different instances of melonDS, both using patched ROMs. I'm able to connect as usual, but trying to interact results in nothing happening. It doesn't loop endlessly, and it doesn't throw an error, it just waits for a moment before saying I failed to respond.

I'll try with my friend when they're available, but should this work?

Posted on 08-22-21 09:56 PM (rev. 2 of 08-22-21 09:57 PM) Link | #4289
If it's either your or their ISP fault, it should. WFC with 2 melonDS instances tho is possible with this method here:
have any of you tested other games?

Posted on 08-22-21 10:51 PM Link | #4291
After following the steps on the linked post, it still fails to respond. I haven't tried other games yet, I'll see if I can test something else and get back to you.

Posted on 08-22-21 10:56 PM Link | #4292
Does the games run at full speed?

Posted on 08-22-21 10:58 PM (rev. 2 of 08-22-21 11:23 PM) Link | #4293
Yes, it does not drop below 60. I have audio sync off and framerate limit on, normally. I have tried with unlimited framerate as well, with similar results.

Posted on 08-23-21 01:05 PM (rev. 2 of 08-23-21 01:06 PM) Link | #4299
tl;dr - Found the reason why it didn't worked locally, but it should have worked online.

Well, I innocently went to test it yesterday to see if it was a server-side issue and I couldn't connect 2 instances either. Then I tried using Wimmfi instead and same result. That bugged me, so I tried to set a specific IP for each instance since it can be sometimes the issue and no matter what IP I used, it would ALWAYS fail.
The IP could be set here along with subnet mask.
That was an interesting result and also reminded me that I didn't tried to do Wi-Fi connections since libslirp became a thing. So this time I tried installing nPcap and trying direct mode instead, and this time it worked! and I could even set the IP(although it wasn't necessary anymore).
Due to that interesting discovery, I tried to connect a instance using libslirp and other using Direct Mode, and if the player using Direct Mode interacts with the player using libslirp the connection would fail... HOWEVER, if instead the player using libslirp interacts with the player using Direct Mode, the connection works!

That said, libslirp through the internet always worked for me whenever I tried, trying it on the same PC tho seems to seems a bit trickier.

Posted on 08-24-21 05:24 AM (rev. 3 of 08-24-21 06:05 AM) Link | #4337
Tested again with my friend, both using patched roms, and still not working. Threw the 86420 error again. Still completely in the dark as to what the actual issue is.

For the sake of clarity (and just to have these all in one post), so far we've tried the following:
- Toggling audio sync and framerate limit
- Toggling JIT recompiler
- Forwarding UDP ports
- Running as administrator
- Switching between AltWFC and Wiimmfi
- Using mobile hotspots
- Erasing WFC settings
- Domain patching ROMs
- Using different (bootable) firmware dumps

mDNS is allowed through both me and my friend's firewalls. We are on different networks. We are using indirect mode.
Every attempt has resulted in either an endless communication loop or error 86420, normally the latter. Is there anything else we should be trying?

(post deleted) #4338

Posted on 08-24-21 05:27 PM Link | #4352
I don't have Skype, but I have Discord if that works. I could PM you my account if you'd like.

Posted on 08-24-21 05:31 PM Link | #4353
there's a melonDS channel on Kuriboh's discord if you want:

(post deleted) #4355
Pages: 1 2

Main - General - Pokemon B/W WiFi Error 86420, Failed to Respond, Endless Loop Hide post layouts | New reply

Page rendered in 0.023 seconds. (2048KB of memory used)
MySQL - queries: 26, rows: 107/107, time: 0.012 seconds.
[powered by Acmlm] Acmlmboard 2.064 (2018-07-20)
© 2005-2008 Acmlm, Xkeeper, blackhole89 et al.