Views: 8,303,286 Homepage | Main | Rules/FAQ | Memberlist | Active users | Last posts | Calendar | Stats | Online users | Search 07-18-24 06:15 PM
Guest:

0 users reading Screen Flicker When Using Fast Forward With 0.9.5 | 1 bot

Main - Compatibility / Testing - Screen Flicker When Using Fast Forward With 0.9.5 Hide post layouts | New reply


Fireseal
Posted on 11-12-22 01:37 AM Link | #5632
First, thanks for all your hard work! Love melonDS and 0.9.5 is looking great, especially with vsync implimented.

I'm having an issue I didn't have with 0.9.4 though, when I "go into" or "come out of" Fast Forward I get black screen flicker.
Tried all of the video modes (software, opengl, vsync on/off, etc) and messing with the settings in my nVidia drivers quite a bit, but couldn't find a setting where the flickering went away.
Fire up 0.9.4, Fast Forward to my heart's content and no flickering.

I want to stick with 0.9.5 especially because I love the vsync but the flickering is a bummer.

Any ideas?

Generic aka RSDuck
Posted on 11-12-22 01:58 AM Link | #5633
your GPU probably doesn't like it if we push frames to it as fast as we want. This can probably be fixed relatively easy though, we just need to skip presenting frames sometimes while fast forwarding.

____________________
Take me to your heart / never let me go!

"clearly you need to mow more lawns and buy a better pc" - Hydr8gon

Fireseal
Posted on 11-12-22 02:02 AM Link | #5634
Thanks for the quick reply!

Would posting my system specs help?
I'm playing Dragon Quest IX if it makes any difference.

Again, the flicker is not present in 0.9.4 with identical settings.

iamtheplauge
Posted on 02-19-24 10:15 PM Link | #6441
Mine does the exact same thing on Pokémon White, coming in and out of fast-forwarding.

superb9393
Posted on 04-12-24 10:30 PM Link | #6525
I managed to fix this in MelonDS 0.9.5 running Pokemon Renegade Platinum.

Go to Config > Video Settings and pick these options:

3D Renderer: Software.
OpenGL display: enable it.
Vsync: disable it.
Vsync interval: 1
Software renderer: enable "Use separate thread".

Hope this helps!

conco
Posted on 05-01-24 03:04 PM Link | #6586
Posted by superb9393
I managed to fix this in MelonDS 0.9.5 running Pokemon Renegade Platinum.

Go to Config > Video Settings and pick these options:

3D Renderer: Software.
OpenGL display: enable it.
Vsync: disable it.
Vsync interval: 1
Software renderer: enable "Use separate thread".

Hope this helps!


This does work, but it sucks that you're forced to sacrifice the increased internal resolution for it - games are pretty blurry on "software", unless I'm missing a way to customize the resolution within that.

LEGO_Vince
Posted on 05-28-24 08:19 PM Link | #6675
I keep on forgetting there's a fast-forward feature. Maybe it's because I keep forgetting there's hotkeys.

____________________
THE LEGO MAN

kikilxve
Posted on 05-28-24 09:04 PM Link | #6677
I never knew it worked because on mobile it didn't and i don't mess with settings that much. Welp, as they say, every day you learn a new thing. :)

____________________
i love pinkpantheress -v-
~ 'Cause i just had a dream i was dead, and i only cared, 'cause i was taken from you ~ | ~ || PinkPantheress - Mosquito || ~
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
go to https://pict.chat (sometimes i'm there)
https://dontasktoask.com
filler text


Main - Compatibility / Testing - Screen Flicker When Using Fast Forward With 0.9.5 Hide post layouts | New reply

Page rendered in 0.032 seconds. (2048KB of memory used)
MySQL - queries: 28, rows: 91/91, time: 0.026 seconds.
[powered by Acmlm] Acmlmboard 2.064 (2018-07-20)
© 2005-2008 Acmlm, Xkeeper, blackhole89 et al.