Views: 7,898,213 Homepage | Main | Rules/FAQ | Memberlist | Active users | Last posts | Calendar | Stats | Online users | Search 06-25-24 04:06 PM
Guest:

0 users reading Build Error (ECM) | 1 bot

Main - Development - Build Error (ECM) Hide post layouts | New reply


Amnesia1000
Posted on 10-19-22 01:22 AM Link | #5597
Hi, I am trying to compile the latest version of git on Linux, and I get this error:
'CMake Error at src/frontend/qt_sdl/CMakeLists.txt:113 (find_package):
Could not find a package configuration file provided by "ECM" with any of
the following names:

ECMConfig.cmake
ecm-config.cmake

Add the installation prefix of "ECM" to CMAKE_PREFIX_PATH or set "ECM_DIR"
to a directory containing one of the above files. If "ECM" provides a
separate development package or SDK, be sure it has been installed.'

CasualPokePlayer
Posted on 10-19-22 01:41 AM (rev. 2 of 10-19-22 01:42 AM) Link | #5598
That just means you don't have ECM installed. If you're on some Debian/Ubuntu distro then doing sudo apt install extra-cmake-modules should fix it (if you're on some other distro the package is probably called extra-cmake-modules).

Amnesia1000
Posted on 10-19-22 02:20 AM Link | #5599
Excelent! Thanks

RustyAlmaza
(post deleted) #5681


Main - Development - Build Error (ECM) Hide post layouts | New reply

Page rendered in 0.041 seconds. (2048KB of memory used)
MySQL - queries: 27, rows: 74/74, time: 0.036 seconds.
[powered by Acmlm] Acmlmboard 2.064 (2018-07-20)
© 2005-2008 Acmlm, Xkeeper, blackhole89 et al.