Views: 1,268,858 Homepage | Main | Rules/FAQ | Memberlist | Active users | Last posts | Calendar | Stats | Online users | Search 12-01-20 06:45 AM
Guest:

Main - Posts by Froufroubizou


Froufroubizou
Posted on 03-02-19 12:15 PM, in Issue when compiling Link | #885
Hi,

I have a problem when I follow the "How to build" instructions:

Compiling errors :

/tmp/cchGoEWP.ltrans17.ltrans.o : Dans la fonction « Wifi::DeInit() » :
:(.text+0x12c5) : undefined reference to « LAN::DeInit() »
/tmp/cchGoEWP.ltrans23.ltrans.o : Dans la fonction « OnOpenWifiSettings(uiMenuItem*, uiWindow*, void*) » :
:(.text+0x121) : undefined reference to « DlgWifiSettings::Open() »
/tmp/cchGoEWP.ltrans26.ltrans.o : Dans la fonction « WifiAP::RecvPacket(unsigned char*) » :
:(.text+0x14d) : undefined reference to « LAN::RecvPacket(unsigned char*) »
/tmp/cchGoEWP.ltrans26.ltrans.o : Dans la fonction « WifiAP::SendPacket(unsigned char*, int) » :
:(.text+0xbf5) : undefined reference to « LAN::SendPacket(unsigned char*, int) »
/tmp/cchGoEWP.ltrans27.ltrans.o : Dans la fonction « Platform::LAN_RecvPacket(unsigned char*) » :
:(.text+0x1561) : undefined reference to « LAN::RecvPacket(unsigned char*) »
/tmp/cchGoEWP.ltrans27.ltrans.o : Dans la fonction « Platform::LAN_SendPacket(unsigned char*, int) » :
:(.text+0x1571) : undefined reference to « LAN::SendPacket(unsigned char*, int) »
/tmp/cchGoEWP.ltrans27.ltrans.o : Dans la fonction « Platform::LAN_DeInit() » :
:(.text+0x1581) : undefined reference to « LAN::DeInit() »
/tmp/cchGoEWP.ltrans27.ltrans.o : Dans la fonction « Platform::LAN_Init() » :
:(.text+0x1591) : undefined reference to « LAN::Init() »
/tmp/cchGoEWP.ltrans30.ltrans.o : Dans la fonction « NDS::DeInit() » :
:(.text+0xe52) : undefined reference to « LAN::DeInit() »
collect2: error: ld returned 1 exit status
CMakeFiles/melonDS.dir/build.make:1971 : la recette pour la cible « melonDS » a échouée


Can someone help me ?

FFB

Froufroubizou
Posted on 11-21-19 06:28 PM, in "attempt to restore cpsr under bad mode 00, 00002CD4" Link | #1375
Hi,

I followed the instructions on GitHub in order to compile MelonDS. It works, but when I start a game, the screen stays white, with 3 or 4 fps

in the shell :

!! attempt to restore CPSR under bad mode 00, 00002CD4
bad CPU mode 00000C0
bad CPU mode 00000C0
!! attempt to restore CPSR under bad mode 00, 00002CD4
bad CPU mode 00000C0
bad CPU mode 00000C0
... et caetera (it loops)

Do you have an idea of this problem meaning ?

Thank you,

FFB


Main - Posts by Froufroubizou

Page rendered in 0.013 seconds. (2048KB of memory used)
MySQL - queries: 22, rows: 67/67, time: 0.010 seconds.
[powered by Acmlm] Acmlmboard 2.064 (2018-07-20)
© 2005-2008 Acmlm, Xkeeper, blackhole89 et al.