Views: 901,643 Homepage | Main | Rules/FAQ | Memberlist | Active users | Last posts | Calendar | Stats | Online users | Search 08-08-20 07:10 PM
Guest:

0 users reading Glitch with Pokémon Platinum Underground | 1 bot

Main - Compatibility / Testing - Glitch with Pokémon Platinum Underground New reply


KingBrCl
Posted on 12-28-19 09:00 PM (rev. 2 of 12-29-19 11:14 PM) Link | #1439
Whenever I use the Explorer's Kit to go underground, I find myself trapped there: all attempts to leave lead to my character freezing in place and the top screen going black. Is there a way to fix this problem?

AshenPhoenix
Posted on 07-28-20 01:03 PM Link | #2125
Yep, the glitch still happens, and it's not just Platinum. Happened for me also in Pearl: when you pick the option to get out of underground, upper screen fades to black, but the character does nothing, remains frozen in place as controls also lock up and music continues playing. Can get pretty frustrating, when you spend quite a lot of time digging up stuff like evolutionary stones and rare bones, because there's no way to save without leaving underground. Not sure what can cause that. However, it doesn't happen every time, not for me at least. Sometimes I'm able to leave just fine, with all of the loot.

[image]

Generic aka RSDuck
Posted on 07-28-20 04:54 PM Link | #2126
can you provide us with a save state?

____________________
Take me to your heart / never let me go!

Can't anybodyyyyyyy find meeeeee someone tooooo hate?

AshenPhoenix
(post deleted) #2131

AshenPhoenix
Posted on 07-29-20 01:07 PM Link | #2134
Yes! This took quite a few digs, as I mentioned, it doesn't happen every time, especially when I was fishing for this glitch on purpose, haha. But when I took an honest attempt, it glitched, so I think it either happens when you spend some more time (20 mins+) in the underground or you move a lot of items to the bag, then try to get out, maybe both of these things, maybe neither. It never happened when I was just running around without digging, no cheats used other than changing the system date to make dig sites appear.

https://www.mediafire.com/file/cwdpkft9wcxxiz9/Pokemon+Pearl.ml1/file

Also excuse me for being a dummy at forum using.

Generic aka RSDuck
Posted on 07-29-20 01:51 PM Link | #2135
thank you this was really helpful because it confirmed that this is likely the same issue as with Pokemon B/W where it can happen if you enable the C-Gear

____________________
Take me to your heart / never let me go!

Can't anybodyyyyyyy find meeeeee someone tooooo hate?

AshenPhoenix
Posted on 07-30-20 09:11 AM Link | #2137
I didn't even know there was such a glitch in B/W. I managed to snag another save state, which isn't exactly softocked, but seems to have 100% lockup rate upon attempting to leave underground, if there is a way of getting around it, I sadly didn't discover it yet. I don't know if that's going to help any more, but nonetheless.

https://www.mediafire.com/file/zsibb0hidk3yic9/Pokemon+Pearl.ml2/file

Anyway, I hope there is a way to fix this glitch.

Generic aka RSDuck
Posted on 08-02-20 10:39 AM Link | #2156
Posted by AshenPhoenix
other than changing the system date to make dig sites appear.

did you change the date while the game was running?

____________________
Take me to your heart / never let me go!

Can't anybodyyyyyyy find meeeeee someone tooooo hate?

AshenPhoenix
Posted on 08-02-20 03:25 PM Link | #2157
Nope, after seeing no dig sites I turned off entire emulator, changed the date and powered it back on

Generic aka RSDuck
Posted on 08-02-20 04:00 PM Link | #2158
hm, I tried reproducing it today, though without success.

____________________
Take me to your heart / never let me go!

Can't anybodyyyyyyy find meeeeee someone tooooo hate?

AshenPhoenix
Posted on 08-03-20 12:41 PM (rev. 2 of 08-03-20 12:43 PM) Link | #2162
I went ahead and tried digging today, sadly glitch is still very much present in the current melon build :( I'm almost fully positive it has either something to do with long time spent underground or big number of items moved from treasure slot to the bag, or maybe the amount of digging done. Either way, it's very frustrating because of this, I really hope it can be narrowed down and fixed at some point.

Generic aka RSDuck
Posted on 08-03-20 12:57 PM Link | #2163
can you give me your save file and tell me which exact game (and it's region) you're playing?

____________________
Take me to your heart / never let me go!

Can't anybodyyyyyyy find meeeeee someone tooooo hate?

AshenPhoenix
Posted on 08-03-20 01:04 PM (rev. 2 of 08-03-20 01:05 PM) Link | #2164
Alrighty. Playing US Pokemon Pearl rev 5, heres the save: http://www.mediafire.com/file/gjsq2prd600xe5y/Pokemon_Pearl.sav/file

Although this glitch also happened to me before on US Pokemon Platinum (no rev) as well, which I'm guessing the op also encountered, but I don't have the save to that anymore.

Generic aka RSDuck
Posted on 08-04-20 11:01 AM (rev. 2 of 08-04-20 11:06 AM) Link | #2165
I didn't manage to reproduce your bug yet, but another one where the game itself says "communication error occured"

EDIT: the same game seems to hung itself up. It said one could press A to return to the last save, but it crashed.

AshenPhoenix
Posted on 08-05-20 09:46 AM Link | #2169
I've encountered this bug once and never again, when I finished digging one place. I have no idea how to reproduce that one. I'm sorry I can't be of any more help, reproducing the bug originally reported seemed easy, but time consuming to me.

Generic aka RSDuck
Posted on 08-07-20 04:20 PM Link | #2186
can you try this build? http://kuribo64.net/get.php?id=VWDmcn9Z5mOlxzhm

____________________
Take me to your heart / never let me go!

Can't anybodyyyyyyy find meeeeee someone tooooo hate?


Main - Compatibility / Testing - Glitch with Pokémon Platinum Underground New reply

Page rendered in 0.025 seconds. (2048KB of memory used)
MySQL - queries: 29, rows: 108/108, time: 0.018 seconds.
[powered by Acmlm] Acmlmboard 2.064 (2018-07-20)
© 2005-2008 Acmlm, Xkeeper, blackhole89 et al.