Views: 839,182 Homepage | Main | Rules/FAQ | Memberlist | Active users | Last posts | Calendar | Stats | Online users | Search 07-04-20 10:40 AM
Guest:

0 users reading Audio problem on slow computers | 1 bot

Main - Compatibility / Testing - Audio problem on slow computers New reply


MegaPikachu20
Posted on 10-14-19 02:11 PM Link | #1307
I seem to be having problems with my audio when I play games like Pokemon, Mario Kart and Fire Emblem. The audio seems to work fine until there's 3D images appearing, which causes the audio to be slow and scary sounding, and drop FPS down about usually above 40s to 50s. Desmume also has this similar problem, the audio is slow but not slow-pitched. I'm using a bad laptop that runs Windows 10, and uses Intel Celeron CPU N3450 @ 1.10 GHz with 4 GB of RAM.

Arisotura
Posted on 10-14-19 02:13 PM Link | #1308
melonDS has synchronous audio as the only option, so if it runs below 60FPS, it'll sound like shit, alas.

DeSmuME may not have this problem because it has asynchronous audio enabled by default. I don't support that because it brings a whole range of emulation problems.

____________________
Kuribo64

squeegily
Posted on 03-25-20 09:17 PM (rev. 3 of 03-26-20 08:28 PM) Link | #1564
Things to try (as of v0.8.3):
  • 2x (or lower) render scale
  • disable/enable JIT
  • disable/enable framerate limit
  • disable/enable audio sync
  • permutations of the above

that said, yea, a 1.xGHz GPU for an emulator with specialized audio requirements…I'm honestly surprised it's working as well as you described


Main - Compatibility / Testing - Audio problem on slow computers New reply

Page rendered in 0.022 seconds. (2048KB of memory used)
MySQL - queries: 29, rows: 82/82, time: 0.018 seconds.
[powered by Acmlm] Acmlmboard 2.064 (2018-07-20)
© 2005-2008 Acmlm, Xkeeper, blackhole89 et al.