Views: 2,175,339 Homepage | Main | Rules/FAQ | Memberlist | Active users | Last posts | Calendar | Stats | Online users | Search 06-21-21 12:57 PM
Guest:

0 users reading The wifi thread | 1 bot

Main - General - The wifi thread New reply

Pages: 1 2 3 4 5
xxDragonSlayerxx
Posted on 10-10-19 03:58 AM Link | #1266
Connecting the emulator to a real DS appears to be a thing some people are wanting. I've seen it mentioned that it's currently not implemented as a feature, but tomorrow I am going to try to test it with friends as an experiment. Hopefully it works.

Either way, MelonDS is an amazing project from its developers. Thank you, Arisotura and Co.

poudink
Posted on 10-10-19 08:37 AM Link | #1267
it's not implemented so there's no point in trying

____________________
Nothing to say, so jadnjkfmnjamnfjkldnajfnjkanfjdksan jsdnvj m.

Sorer
Posted on 10-10-19 11:39 AM Link | #1268
Well if you count online Wi-Fi than you can connect to a real DS...

Arisotura
Posted on 10-11-19 09:17 AM Link | #1281
yeah, I guess. if you have a WEP or open access point...

local wifi between melonDS and a DS is another story tho

due to the tight timing requirements and the kind of special wifi hardware it'd require, as well as latency induced by OS/drivers/etc, I'm not positive it would ever work.

I still want to try it out, tho.

____________________
Kuribo64

Sorer
Posted on 10-11-19 09:45 AM Link | #1282
I remember that Citra developers said the same about their implementation of local wifi.
Although their is local wifi that works over the internet and also over LAN/Same PC.
It's just that Console to PC and vice versa is a problem.

xxDragonSlayerxx
Posted on 10-12-19 12:55 AM Link | #1292
The experiment failed as expected.
You're right about local wifi being an issue and I can understand that. However, it's reasonable to suspect that most people will be in range of an AP. A friend sent me this https://www.youtube.com/watch?v=bdWCH-3iPlE which includes a lot of information regarding this process in the description for anyone else who would like to try.

Mark
Posted on 10-01-20 09:45 AM Link | #2493
hello there i seem to be having a problem and my problem is that seems to be my connection setup because for some reason i keep getting error code 52000 if anyone could help me i would appreciate it

Generic aka RSDuck
Posted on 10-01-20 09:59 AM Link | #2495
Posted by xxDragonSlayerxx
The experiment failed as expected.
You're right about local wifi being an issue and I can understand that. However, it's reasonable to suspect that most people will be in range of an AP. A friend sent me this https://www.youtube.com/watch?v=bdWCH-3iPlE which includes a lot of information regarding this process in the description for anyone else who would like to try.

can you please tell your friend not to bundle melonDS in dubious rar files and instead link to our download page where users can download the latest release?


Posted by Mark
hello there i seem to be having a problem and my problem is that seems to be my connection setup because for some reason i keep getting error code 52000 if anyone could help me i would appreciate it

is it possible that you're using either an old version and/or that you're using Direct Mode while you're connected to the internet via wifi?

____________________
Take me to your heart / never let me go!

"clearly you need to mow more lawns and buy a better pc" - Hydr8gon

Mark
Posted on 10-01-20 10:53 AM (rev. 3 of 10-01-20 11:01 AM) Link | #2498
it seems im using melonds version 9 and im using ethernet


Posted by Generic aka RSDuck
can you please tell your friend not to bundle melonDS in dubious rar files and instead link to our download page where users can download the latest release?


is it possible that you're using either an old version and/or that you're using Direct Mode while you're connected to the internet via wifi?


it seems like i had been using the normal internet but now i tried with ethernet and it gives me error code 52100 also do you know what the gateway is and the subnet mask?


Posted by Generic aka RSDuck
can you please tell your friend not to bundle melonDS in dubious rar files and instead link to our download page where users can download the latest release?


is it possible that you're using either an old version and/or that you're using Direct Mode while you're connected to the internet via wifi?


it seems like i had been using the normal internet but now i tried with ethernet and it gives me error code 52100 also do you know what the gateway is and the subnet mask?

Generic aka RSDuck
Posted on 10-01-20 11:03 AM Link | #2501
Posted by Mark
it seems im using melonds version 9 and im using ethernet



it seems like i had been using the normal internet but now i tried with ethernet and it gives me error code 52100 also do you know what the gateway is and the subnet mask?



it seems like i had been using the normal internet but now i tried with ethernet and it gives me error code 52100 also do you know what the gateway is and the subnet mask?

did you try the indirect mode, it should work out of the box? Direct mode isn't recommended anymore.

____________________
Take me to your heart / never let me go!

"clearly you need to mow more lawns and buy a better pc" - Hydr8gon

Sorer
Posted on 10-01-20 04:59 PM Link | #2516
Posted by Generic aka RSDuck
can you please tell your friend not to bundle melonDS in dubious rar files and instead link to our download page where users can download the latest release?


is it possible that you're using either an old version and/or that you're using Direct Mode while you're connected to the internet via wifi?


Well it seems like the video is old and maybe the wifi related code was not in the latest official release.
Or it contains files for easy configuration of the emulator lol.

Jackwolf5775
Posted on 11-08-20 12:01 AM Link | #2706
I'm currently trying to set up MelonDS wifi so I can play some games online, however, whenever I test the connection, I get error code "52100." This occurs with both DNS's I've seen as viable, in the test connect and when I try connecting in-game. My PC is in rough shape right now, since my good graphics card died and I have no on-board graphics I've had to use one not compatible with my current OS, but MelonDS itself runs well.

I have no access to the router I'm using for internet, since I'm on (honestly very, very solid) college internet. Ethernet connection, direct connect on, NPCap downloaded, the appropriate connection for my ethernet cable selected, all that is set up as well. I'm following Aphelion Gaming's video "MelonDS Full Setup Guide - DS/DSI Emulator For PC," and this is the only part that doesn't go as in the video. He appears to be on an older version than me, 0.8.3 as opposed to 0.9, but I don't believe that's enough of a difference.

Some research of my own indicated that error code 52100 is often associated with some router trouble, but I can't find any further information on the exact cause or any solutions, exacerbated by my lack of access to the college router. If anyone can tell me where things are going wrong and how I can fix it, it'd be greatly appreciated.

WaluigiWare64
Posted on 11-08-20 05:03 AM Link | #2707

You don't need to use Direct Mode, you can use the new Indirect Mode with melonDS 0.9.
Disable Direct Mode in the settings and melonDS will automatically use Indirect Mode, which is more reliable.

____________________

How to write an emulator
1. throw code to be emulated somewhere
2. make memory system that allows accessing that code
3. emulate CPU
4. have fun implementing all the other hardware
-- Arisotura, Tuesday 5th January 2021, 22:00:17



Jackwolf5775
Posted on 11-08-20 12:45 PM Link | #2709
Posted by WaluigiWare64
You don't need to use Direct Mode, you can use the new Indirect Mode with melonDS 0.9.
Disable Direct Mode in the settings and melonDS will automatically use Indirect Mode, which is more reliable.

I tried Indirect mode, but I'm still getting the same error messages. 52100 if I try a DNS for ALTWFC, 52101 if I try for Wiimmfi. I don't think this is caused by direct or indirect mode.

WaluigiWare64
Posted on 11-08-20 01:09 PM Link | #2710

https://wiimmfi.de/error?e=52100


____________________

How to write an emulator
1. throw code to be emulated somewhere
2. make memory system that allows accessing that code
3. emulate CPU
4. have fun implementing all the other hardware
-- Arisotura, Tuesday 5th January 2021, 22:00:17



Sorer
Posted on 11-10-20 04:29 PM Link | #2715
Posted by Jackwolf5775
I tried Indirect mode, but I'm still getting the same error messages. 52100 if I try a DNS for ALTWFC, 52101 if I try for Wiimmfi. I don't think this is caused by direct or indirect mode.


Look up in this thread or in previous ones on this forum for a solution.
It got something to do with the ISP/router blocking the DNS from working on your PC.

Jackwolf5775
Posted on 11-10-20 06:28 PM Link | #2716
Posted by Sorer
Look up in this thread or in previous ones on this forum for a solution.
It got something to do with the ISP/router blocking the DNS from working on your PC.

Then I might be boned since I can't access the router (college internet) and I have no idea how to modify the DNS since the only tutorial I can find on DNS settings is about some google stuff. That said, there *is* another update in that I found a problem on my end relating to modifying the DS internet settings in a game. Whenever I change the wi-fi settings in Final Fantasy: Crystal Chronicles, Echoes of Time, the firmware.bin file stops working, booting to a white screen and never passing it. I can still load games if I skip firmware, but the issues might be related in some way I don't understand.

WaluigiWare64
Posted on 11-11-20 02:42 PM Link | #2717

Posted by Jackwolf5775
That said, there *is* another update in that I found a problem on my end relating to modifying the DS internet settings in a game. Whenever I change the wi-fi settings in Final Fantasy: Crystal Chronicles, Echoes of Time, the firmware.bin file stops working, booting to a white screen and never passing it. I can still load games if I skip firmware, but the issues might be related in some way I don't understand.

That means you've downloaded those old hacked firmware dumps.

____________________

How to write an emulator
1. throw code to be emulated somewhere
2. make memory system that allows accessing that code
3. emulate CPU
4. have fun implementing all the other hardware
-- Arisotura, Tuesday 5th January 2021, 22:00:17



Athanatos
Posted on 12-28-20 01:36 AM (rev. 2 of 12-28-20 01:49 AM) Link | #3037
Hi all, I have an issue with Pokémon Black Version 2. I have a copy of White 2 (it's technically only on an emulator on my custom firmware 3DS, but I've tested it and it has complete Wi-Fi capability and no problems connecting with my actual cartridge games) that I'm trying to connect to Black 2 from melonDS. I have used this copy of White Version 2 to connect to my actual games (White Version 1) with C-Gear, to battle and trade with them, and there's no issue. However, when I try to have the Black 2 show up in C-Gear, it doesn't - and Unova Link doesn't work either. However, Wi-Fi seems to be fully functional, as my configurations on Melon let me use the GTS on Black 2 no problem. So, my question is, what is the problem with Black 2? It connects to Wi-Fi fine with AltWFC but isn't able to connect to the C-Gear at all. Any ideas? Thanks.

Notes:
- Although I don't think this is relevant, as the melonDS Wi-Fi clearly works fine, I will mention: I don't actually have a real "Ethernet" connection. I have a laptop, so I use my iPhone and tether to it's hotspot. When you do this with iTunes, it registers as an Ethernet connection in the internal settings of the laptop. Also, melonDS also seems to believe that it is Ethernet.

- Wi-Fi settings in melonDS are such:
Bind socket to any address: checked.
Randomize MAC address: left blank.
Direct Mode selected.
Network adaptor: Ethernet.

Any help is tremendously appreciated!!!

TLDR: Pokémon Black Version 2, WFC works fine but C-Gear doesn't work at all.


Edit: Hi again, quick edit - I'm actually becoming less convinced that Wi-Fi is working on melonDS.
- 1: While I can connect to GTS, it seems that no matter what Pokemon I choose, the game tells me it wasn't found. I'm positive that on AltWFC at least some of those Pokemon would be available - I tried a ton. Also, I tried connecting to my White Version 2 through the Musical Theater, which gives you the option to choose strictly between Infrared (which is a C-Gear feature) and DS Wireless Connections. I chose the latter, and couldn't connect to my White 2 copy - even though that's a feature I've utilized before. Thanks again for any help.

Generic aka RSDuck
Posted on 12-28-20 02:27 AM Link | #3038
1. could it be possible that you have mixed up wifi and wireless communication? Wireless is only emulated for melonDS <-> melonDS because your computer can't send a signal which the DS can pickup. Wifi on the other hand works between emulator and a real game because it requires a server in the middle.
2. Not every WFC replacement server supports all functionality (Battling, personal trading, GTS, battle camera…). https://pkmnclassic.net/ is specialised in Pokemon I think they provide most of it.
3. Don't use direct mode anymore. With 0.9 or later indirect mode (direct mode being disabled) is the recommend setting because it doesn't require pcap or an ethernet connection.

____________________
Take me to your heart / never let me go!

"clearly you need to mow more lawns and buy a better pc" - Hydr8gon
Pages: 1 2 3 4 5

Main - General - The wifi thread New reply

Page rendered in 0.025 seconds. (2048KB of memory used)
MySQL - queries: 29, rows: 116/116, time: 0.018 seconds.
[powered by Acmlm] Acmlmboard 2.064 (2018-07-20)
© 2005-2008 Acmlm, Xkeeper, blackhole89 et al.